<!DOCTYPE html><html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" prefix="og: http://ogp.me/ns#">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Santa Maria Grilled Tri-Tip Steak | AM 1370 KDTH</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0"/>
<meta name="google-site-verification" content="FxxbxrSXpo4sTPKAtrLHwAJVsixGPlQlOOsuZa-UrzE" />
<link rel="stylesheet" href="http://kdth.radiodubuque.com/wp-content/themes/MagSeven/lib/css/reset.css" type="text/css" media="screen, projection" />
<link rel="stylesheet" href="http://kdth.radiodubuque.com/wp-content/themes/MagSeven/lib/css/defaults.css" type="text/css" media="screen, projection" />
<!--[if lt IE 8]><link rel="stylesheet" href="http://kdth.radiodubuque.com/wp-content/themes/MagSeven/lib/css/ie.css" type="text/css" media="screen, projection" /><![endif]-->

<link rel="stylesheet" href="http://kdth.radiodubuque.com/wp-content/themes/MagSeven-Child-KDTH/style.css" type="text/css" media="screen, projection" />

<script language=javascript src="http://nick8.surfernetwork.com/Media/player/scripts/launch.js"></script>


<!-- This site is optimized with the Yoast SEO plugin v4.9 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://kdth.radiodubuque.com/santa-maria-grilled-tri-tip-steak/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Santa Maria Grilled Tri-Tip Steak - AM 1370 KDTH" />
<meta property="og:description" content="Santa Maria Grilled Tri-Tip Steak  2 ½-3 lb. Tri-Tip Steak  Dry Rub mix: 1 tablespoon salt 1 tablespoon black pepper 1 tablespoon garlic powder 1 ½ teaspoon paprika 1 tablespoon onion powder 1 teaspoon cayenne 1 tablespoon dried oregano 1 teaspoon dry thyme  Baste mixture: 1/3 cup red wine vinegar 1/3 cup vegetable oil 2" />
<meta property="og:url" content="http://kdth.radiodubuque.com/santa-maria-grilled-tri-tip-steak/" />
<meta property="og:site_name" content="AM 1370 KDTH" />
<meta property="article:section" content="Cookin&#039; with Kaye" />
<meta property="article:published_time" content="2017-06-23T06:28:10-05:00" />
<meta property="article:modified_time" content="2017-06-23T08:45:39-05:00" />
<meta property="og:updated_time" content="2017-06-23T08:45:39-05:00" />
<meta property="og:image" content="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2017/06/Santa-Maria-Grilled-Tri-Tip-Steak-004-300x225.jpg" />
<meta property="og:image" content="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2017/06/Santa-Maria-Grilled-Tri-Tip-Steak-007-300x225.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="AM 1370 KDTH &raquo; Santa Maria Grilled Tri-Tip Steak Comments Feed" href="http://kdth.radiodubuque.com/santa-maria-grilled-tri-tip-steak/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/kdth.radiodubuque.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ap-fileuploader-animation-css'  href='http://kdth.radiodubuque.com/wp-content/plugins/accesspress-anonymous-post-pro/css/loading-animation.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='ap-fileuploader-css'  href='http://kdth.radiodubuque.com/wp-content/plugins/accesspress-anonymous-post-pro/css/fileuploader.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='ap-jquery-ui-style-css'  href='//ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/themes/smoothness/jquery-ui.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='ap-front-styles-css'  href='http://kdth.radiodubuque.com/wp-content/plugins/accesspress-anonymous-post-pro/css/frontend-style.css?ver=3.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='ap-lightbox-css-css'  href='http://kdth.radiodubuque.com/wp-content/plugins/accesspress-anonymous-post-pro/lightbox/css/lightbox.css?ver=3.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='events-manager-css'  href='http://kdth.radiodubuque.com/wp-content/plugins/events-manager/includes/css/events_manager.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='sccss_style-css'  href='http://kdth.radiodubuque.com?sccss=1&#038;ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://kdth.radiodubuque.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.0' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.2.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	var disableStr = 'ga-disable-UA-15333511-7';
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-15333511-7', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-content/plugins/accesspress-anonymous-post-pro/js/fileuploader.js?ver=4.8'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-content/plugins/accesspress-anonymous-post-pro/lightbox/js/lightbox.js?ver=3.0.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ap_fileuploader = {"upload_url":"http:\/\/kdth.radiodubuque.com\/wp-admin\/admin-ajax.php","nonce":"030bb7e39a"};
var ap_form_required_message = "This field is required";
var ap_captcha_error_message = "Sum is not correct.";
/* ]]> */
</script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-content/plugins/accesspress-anonymous-post-pro/js/frontend.js?ver=3.0.0'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/jquery/ui/sortable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/wp-a11y.min.js?ver=4.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EM = {"ajaxurl":"http:\/\/kdth.radiodubuque.com\/wp-admin\/admin-ajax.php","locationajaxurl":"http:\/\/kdth.radiodubuque.com\/wp-admin\/admin-ajax.php?action=locations_search","firstDay":"1","locale":"en","dateFormat":"mm\/dd\/yy","ui_css":"http:\/\/kdth.radiodubuque.com\/wp-content\/plugins\/events-manager\/includes\/css\/jquery-ui.min.css","show24hours":"0","is_ssl":"","txt_search":"Search","txt_searching":"Searching...","txt_loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-content/plugins/events-manager/includes/js/events-manager.js?ver=5.7'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-content/themes/MagSeven/lib/js/superfish.js?ver=4.8'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-content/themes/MagSeven/lib/js/jquery.mobilemenu.js?ver=4.8'></script>
<link rel='https://api.w.org/' href='http://kdth.radiodubuque.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://kdth.radiodubuque.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://kdth.radiodubuque.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='http://wp.me/p780o2-5e8' />
<link rel="alternate" type="application/json+oembed" href="http://kdth.radiodubuque.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fkdth.radiodubuque.com%2Fsanta-maria-grilled-tri-tip-steak%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://kdth.radiodubuque.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fkdth.radiodubuque.com%2Fsanta-maria-grilled-tri-tip-steak%2F&#038;format=xml" />
<!-- <meta name="vfb" version="2.9.2" /> -->

<!-- This site is using AdRotate v4.4 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

    <style type="text/css" media="screen">
      div.printfriendly a, div.printfriendly a:link, div.printfriendly a:hover, div.printfriendly a:visited {
        text-decoration: none;
        border: none;
      }
    </style>
           <style type="text/css" media="screen">
          div.printfriendly {
            margin: 12px 12px 12px 12px;
            position: relative;
            z-index: 1000;
          }
          div.printfriendly a, div.printfriendly a:link, div.printfriendly a:visited {
            font-size: 14px;
            color: #6D9F00;
            vertical-align: bottom;
          }
          .printfriendly a {
            box-shadow:none;
          }
          .printfriendly a:hover {
            cursor: pointer;
          }
          .printfriendly a img  {
            border: none;
            padding:0;
            margin-right: 6px;
            box-shadow: none;
            -webkit-box-shadow: none;
            -moz-box-shadow: none;
          }
          .printfriendly a span{
            vertical-align: bottom;
          }
          .pf-alignleft {
            float: left;
          }
          .pf-alignright {
            float: right;
          }
          div.pf-aligncenter {
            display: block;
            margin-left: auto;
            margin-right: auto;
            text-align: center;
          }
        </style>
        <style type="text/css" media="print">
          .printfriendly {
            display: none;
          }
        </style>

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style><link rel="shortcut icon" href="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2016/01/kdthfavicon.png" type="image/x-icon" />
<link rel="alternate" type="application/rss+xml" title="AM 1370 KDTH RSS Feed" href="http://kdth.radiodubuque.com/feed/" />
<link rel="pingback" href="http://kdth.radiodubuque.com/xmlrpc.php" />

</head>

<body class="post-template-default single single-post postid-20096 single-format-standard">
<div id="header-bg">
    <div id="container">
        
        <div class="clearfix">
                        
            <div id="listen-live">
            	<a href="javascript:callLTR='KDTH';grptuner='';file='';title='';ListenLive();"><img src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2016/01/listen-live.png" alt="Listen Live"></a>
            </div>
            
            <div id="delays-cancellations">
            	<a href="http://kdth.radiodubuque.com/delays-and-cancellations"><img src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2016/03/Delays-and-Cancellations-Icon.png" alt="Delays and Cancellations" /></a>
            </div>
            
            <div id="top-social-profiles">
                            <ul class="widget-container"><li class="social-profiles-widget">
            <a href="https://twitter.com/AM1370KDTH" target="_blank"><img title="Twitter" alt="Twitter" src="http://kdth.radiodubuque.com/wp-content/themes/MagSeven/images/social-profiles/twitter.png" /></a><a href="https://www.facebook.com/AM-1370-KDTHThe-Voice-of-the-Tri-States-403149500489/" target="_blank"><img title="Facebook" alt="Facebook" src="http://kdth.radiodubuque.com/wp-content/themes/MagSeven/images/social-profiles/facebook.png" /></a><a href="http://kdth.radiodubuque.com/feed/" target="_blank"><img title="RSS Feed" alt="RSS Feed" src="http://kdth.radiodubuque.com/wp-content/themes/MagSeven/images/social-profiles/rss.png" /></a><a href="mailto:kdth@kdth.com" target="_blank"><img title="Email" alt="Email" src="http://kdth.radiodubuque.com/wp-content/themes/MagSeven/images/social-profiles/email.png" /></a>            </li></ul>
                        </div>
        </div>
        
    
        <div id="header">
        
            <div class="logo">
             
                <a href="http://kdth.radiodubuque.com"><img src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2016/01/KDTH-1.png" alt="AM 1370 KDTH" title="AM 1370 KDTH" /></a>
             
            </div><!-- .logo -->
    
            <div class="header-right">
                 
                <div class="g g-4"><div class="g-single a-4"><a class="gofollow" data-track="NCw0LDIsNjA=" href="http://www.rundeautogroup.com"  target="_blank"><img src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2017/01/Runde-Auto-Group-2017.jpg" Runde Auto Group  /></a></div></div>            </div><!-- .header-right -->
            
        </div><!-- #header -->
    </div>
</div>

<div id="container">
        
                    <div class="clearfix">
                			<div class="menu-secondary-container"><ul id="menu-main-menu" class="menus menu-secondary"><li id="menu-item-56" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-56"><a href="http://kdth.radiodubuque.com/">Home</a></li>
<li id="menu-item-57" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-57"><a href="http://kdth.radiodubuque.com/about-us/">About Us</a>
<ul  class="sub-menu">
	<li id="menu-item-170" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170"><a href="http://kdth.radiodubuque.com/about-us/">History</a></li>
	<li id="menu-item-58" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-58"><a href="http://kdth.radiodubuque.com/about-us/staff/">Staff</a>
	<ul  class="sub-menu">
		<li id="menu-item-285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-285"><a href="http://kdth.radiodubuque.com/about-us/staff/">On-Air</a></li>
		<li id="menu-item-286" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-286"><a href="http://kdth.radiodubuque.com/about-us/staff/sales-and-support/">Sales and Support</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-61" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-61"><a href="http://kdth.radiodubuque.com/news/dubuque-tri-state-news/">News</a>
<ul  class="sub-menu">
	<li id="menu-item-62" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62"><a href="http://kdth.radiodubuque.com/news/dubuque-tri-state-news/">Dubuque &#038; Tri-State News</a></li>
	<li id="menu-item-63" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63"><a href="http://kdth.radiodubuque.com/news/regional-news/">Regional News</a></li>
	<li id="menu-item-64" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64"><a href="http://kdth.radiodubuque.com/news/national-news/">National News</a></li>
</ul>
</li>
<li id="menu-item-65" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-65"><a href="http://kdth.radiodubuque.com/sports/">Sports</a>
<ul  class="sub-menu">
	<li id="menu-item-107" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-107"><a href="http://kdth.radiodubuque.com/sports-broadcast-schedule/">AM 1370 KDTH Sports Broadcast Schedule</a></li>
	<li id="menu-item-3098" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3098"><a href="http://kdth.radiodubuque.com/sports-podcasts/">Sports Podcasts</a></li>
</ul>
</li>
<li id="menu-item-183" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-183"><a href="http://kdth.radiodubuque.com/weather-forecast/">Weather</a></li>
<li id="menu-item-96" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-96"><a href="http://kdth.radiodubuque.com/voices-of-the-tri-states/">Voices of the Tri-States</a>
<ul  class="sub-menu">
	<li id="menu-item-5818" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5818"><a href="http://kdth.radiodubuque.com/voices-of-the-tri-states/archive-voices-tri-states/">Voices Archive</a></li>
</ul>
</li>
<li id="menu-item-95" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-95"><a href="http://kdth.radiodubuque.com/?page_id=81">Obituaries</a></li>
<li id="menu-item-211" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-211"><a href="http://kdth.radiodubuque.com/kdth-community-calendar/">Community Calendar</a>
<ul  class="sub-menu">
	<li id="menu-item-291" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-291"><a href="http://kdth.radiodubuque.com/kdth-community-calendar/submit-event/">Submit an Event to our Community Calendar</a></li>
</ul>
</li>
<li id="menu-item-91" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-91"><a href="http://kdth.radiodubuque.com/links/">Links</a></li>
<li id="menu-item-93" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-93"><a href="http://kdth.radiodubuque.com/programming/">Programming</a>
<ul  class="sub-menu">
	<li id="menu-item-266" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-266"><a href="http://kdth.radiodubuque.com/cookin-with-kaye/">Cookin&#8217; with Kaye</a></li>
	<li id="menu-item-1237" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1237"><a href="http://kdth.radiodubuque.com/programming/the-big-broadcast/">The Big Broadcast</a></li>
</ul>
</li>
<li id="menu-item-92" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-92"><a href="http://kdth.radiodubuque.com/contest-rules/">Contest Rules</a></li>
<li id="menu-item-59" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-59"><a href="http://kdth.radiodubuque.com/contact-us/">Contact Us</a>
<ul  class="sub-menu">
	<li id="menu-item-213" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-213"><a href="http://kdth.radiodubuque.com/advertise/">Advertise</a></li>
</ul>
</li>
</ul></div>              <!--.secondary menu--> 	
                    </div>
        
    <div id="main">
    
            
        <div id="content">
            
                    
            
    <div class="post post-single clearfix post-20096 type-post status-publish format-standard hentry category-cookin-with-kaye" id="post-20096">
    
        <h1 class="title">Santa Maria Grilled Tri-Tip Steak</h1>
        
        <div class="postmeta-primary">
    
            <span class="meta_date">June 23, 2017</span>
           &nbsp; <span class="meta_categories"><a href="http://kdth.radiodubuque.com/cookin-with-kaye/" rel="category tag">Cookin' with Kaye</a></span>
    
                 
        </div>
        
        <div class="entry clearfix">
            
                        
            <div class="pf-content"><p><strong>Santa Maria Grilled Tri-Tip Steak</strong><strong> </strong></p>
<p><strong>2 ½-3 lb. Tri-Tip Steak</strong><strong> </strong></p>
<p><strong><u>Dry Rub mix</u></strong><strong>:</strong></p>
<p><strong>1 tablespoon salt</strong></p>
<p><strong>1 tablespoon black pepper</strong></p>
<p><strong>1 tablespoon garlic powder</strong></p>
<p><strong>1 ½ teaspoon paprika</strong></p>
<p><strong>1 tablespoon onion powder</strong></p>
<p><strong>1 teaspoon cayenne</strong></p>
<p><strong>1 tablespoon dried oregano</strong></p>
<p><strong>1 teaspoon dry thyme</strong><strong> </strong></p>
<p><strong><u>Baste mixture</u></strong><strong>:</strong></p>
<p><strong>1/3 cup red wine vinegar</strong></p>
<p><strong>1/3 cup vegetable oil</strong></p>
<p><strong>2 teaspoons minced garlic</strong></p>
<p><strong>½ teaspoon Dijon mustard</strong><strong> </strong></p>
<p><strong>Mix rub ingredients together in a bowl.  Sprinkle rub on the meat on all sides.  Cover with plastic wrap and refrigerate 4 hours.  When ready to grill, remove from refrigerator and let sit at room temperature for one hour. </strong><strong> </strong></p>
<p><strong>Combine vinegar, vegetable oil, minced garlic and Dijon mustard together in a sealable container.  Cover the container and shake to blend ingredients. </strong><strong> </strong></p>
<p><strong>Preheat grill for indirect cooking (hot on one side, cool on the other).  Place tri-tip on grill and sear on all sides, 3-4 minutes per side.  Once tri-tip is seared on all sides, move to cool side of the grill and, if your grill has a top rack, place the tri-tip on the upper rack, with an aluminum tray on the bottom rack underneath to catch the fat drippings.  Cover the grill and cook until the internal temperature reaches 130-degrees F, about 25-30 minutes.  Try to keep the grill temperature between 250-300-degrees F.  When done, remove from grill and let it rest, loosely tented with foil, for 10 minutes.  Slice against the grain and serve.</strong></p>
<p><img class="alignnone size-medium wp-image-20105" src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2017/06/Santa-Maria-Grilled-Tri-Tip-Steak-004-300x225.jpg" alt="" width="300" height="225" srcset="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2017/06/Santa-Maria-Grilled-Tri-Tip-Steak-004-300x225.jpg 300w, http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2017/06/Santa-Maria-Grilled-Tri-Tip-Steak-004-768x576.jpg 768w, http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2017/06/Santa-Maria-Grilled-Tri-Tip-Steak-004-1024x768.jpg 1024w, http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2017/06/Santa-Maria-Grilled-Tri-Tip-Steak-004.jpg 1600w" sizes="(max-width: 300px) 100vw, 300px" /> <img class="alignnone size-medium wp-image-20106" src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2017/06/Santa-Maria-Grilled-Tri-Tip-Steak-007-300x225.jpg" alt="" width="300" height="225" srcset="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2017/06/Santa-Maria-Grilled-Tri-Tip-Steak-007-300x225.jpg 300w, http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2017/06/Santa-Maria-Grilled-Tri-Tip-Steak-007-768x576.jpg 768w, http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2017/06/Santa-Maria-Grilled-Tri-Tip-Steak-007-1024x768.jpg 1024w, http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2017/06/Santa-Maria-Grilled-Tri-Tip-Steak-007.jpg 1600w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<div class="printfriendly pf-alignleft"><a href="#" rel="nofollow" onclick="window.print(); return false;" class="noslimstat"><img style="border:none;-webkit-box-shadow:none; box-shadow:none;" src="https://cdn.printfriendly.com/button-print-gry20.png" alt="Print Friendly" /></a></div></div>    
        </div>
        
         
        
    
    </div><!-- Post ID 20096 -->
    
                
                    
        </div><!-- #content -->
    
        
<div id="sidebar-primary">

    <ul class="widget-container"><li id="text-6" class="widget widget_text">			<div class="textwidget"><center>
<a href="http://kdth.radiodubuque.com/sports-broadcast-schedule/"><img src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2016/09/Sports-Broadcasting-Schedule-Football.jpg" alt="Sports Broadcasting Schedule" /></a>

<a href="http://kdth.radiodubuque.com/sports-podcasts/"><img src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2016/09/Sports-Podcast-Archives.jpg" alt="Sports Podcast Archives" /></a>

<a href="http://kdth.radiodubuque.com/category/cookin-with-kaye/"><img src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2016/03/Cookin-with-Kaye.jpg" width="250"></a>
</center></div>
		</li></ul><ul class="widget-container"><li id="text-5" class="widget widget_text">			<div class="textwidget"><center>

<a href="http://www.julienfilmfest.com"></a>

<a href="http://kdth.radiodubuque.com/mothers-day-greetings/"></a>

<a href="http://www.greatgiveday.org"></a>

<a href="http://www.dutrac.org/oh-say-can-you-sing-national-anthem-showcase"></a>

<a href="http://wallofheroes.radiodubuque.com"><img src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2016/04/wallofheroes.jpg" width="190"></a>

<a href="http://fireworks.radiodubuque.com"><img src="http://katfm.radiodubuque.com/wp-content/uploads/sites/3/2017/01/button-2017.jpg" width="190"></a>

</center></div>
		</li></ul><ul class="widget-container"><li id="text-2" class="widget widget_text">			<div class="textwidget"><p><center></p>
<p><a href="http://www.andersonwebertoyota.com/nominate-a-teacher.htm"><img src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2016/02/Anderson-Weber-Teacher-of-the-Month.jpg" alt="Teacher of the Month" width="190" height="190" border="0" /></a></p>
<p><a href="http://kdth.radiodubuque.com/birthdays/"><img src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2016/02/Birthdays-and-Anniversaries.png" alt="Birthdays and Anniversaries" width="190" /></a></p>
<p><a href="http://water.weather.gov//ahps2/hydrograph.php?wfo=dvn&amp;gage=dbqi4&amp;view=1,1,1,1,1,1" target="_blank"><img src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2016/02/River-Stage.gif" alt="River Stage" width="160" height="91" border="0" /></a></p>
<p><a href="http://www.weather.gov/data/obhistory/KDBQ.html" target="_blank"><img src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2016/02/time-and-temp.gif" alt="Time and Temp" width="160" height="72" border="0" /></a></p>
<p><a href="http://katfm.radiodubuque.com" target="_blank"><img src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2016/02/92.9-KAT-FM.png" alt="KAT FM" width="190" border="0" /></a></p>
<p><a href="http://973therock.radiodubuque.com" target="_blank"><img src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2016/02/97.3-the-Rock-KGRR.png" alt="The Rock" width="190" border="0" /></a></p>
<p><a href="http://1011theriver.radiodubuque.com" target="_blank"><img src="http://kdth.radiodubuque.com/wp-content/uploads/sites/2/2016/02/101.1-the-River-WVRE.png" alt="The River" width="190" border="0" /></a><br />
</center></p>
</div>
		</li></ul><ul class="widget-container"><li id="text-8" class="widget widget_text">			<div class="textwidget"><script type="text/javascript"><!--

         //took this from http://www.thedevproject.com/2006/05/08/randomizing-javascript-arrays/
         Array.prototype.shuffle = function() {
           for (var i = 0; i < this.length; i++) {
             // Random item in this array.
             var r = parseInt(Math.random() * this.length);
             var obj = this[r];
 
             // Swap.
             this[r] = this[i];
             this[i] = obj;
           }
         }

         function randomize(tableID) {
         	var myTable = document.getElementById(tableID);
         	var myRows = new Array();
	         for (i=myTable.rows.length-1; i>=0; i--) {
		         var theRow = myTable.rows[i];
		         myRows.push(theRow);
		         theRow.parentNode.removeChild(theRow);
	         }
	         myRows.shuffle();
	         for (j=0; j<myRows.length; j++) {
	         	var newTbody = document.createElement("tbody");
		         newTbody.appendChild(myRows[j]);
		         myTable.appendChild(newTbody);
	         }
         }
         window.onload = function() {
            randomize("randomtableSponsors");
         }
         //-->
         </script>
<table border="0" id="randomtableSponsors">

	<tr>
	<td align="center"><a href="https://www.carlosokellys.com/all-locations/3-iowa/18-dubuque.html" target="_blank"><img src="http://katfm.radiodubuque.com/wp-content/uploads/sites/3/2017/01/Carlos-O-Kelleys.jpg" width="250" /></a></td></tr>
	<tr><td align="center"><a href="http://www.ohnwardfineartscenter.com/" target="_blank"><img src="http://katfm.radiodubuque.com/wp-content/uploads/sites/3/2017/01/Ohnward-Fine-Arts-Center.jpg" width="250" /></a></td></tr>
	<tr><td align="center"><h4><a href="http://www.mollyscanteen.com/Welcome.html" target="_blank">Molly's Silver Screen Canteen</a></h4>
	  <a href="http://www.mollyscanteen.com/Welcome.html"><img src="http://katfm.radiodubuque.com/wp-content/uploads/sites/3/2017/01/Mollys-Silver-Screen-Canteen.jpg" width="150" /></a><br />Give your sweetheart a FREE drink. Buy a Medium drink and get a Medium FREE. From 2/10-2/17/2017. Try a Red Velvet Mocha. Chocolate with your choice of cherry, strawberry, or raspberry.</td></tr>
	<tr><td align="center"><a href="http://sparkleflairandhair.com/" target="_blank"><img src="http://katfm.radiodubuque.com/wp-content/uploads/sites/3/2017/01/Sparkle-Flair-and-Hair.jpg" width="250" /></a><br />GIFT CERTIFICATES AVAILABLE</td></tr>
	<tr><td align="center"><a href="http://stevesace.com/Departments/FlowerShoppe.aspx" target="_blank"><img src="http://katfm.radiodubuque.com/wp-content/uploads/sites/3/2017/01/The-Flower-Shoppe-at-Steves-Ace.png" width="250" /></a><br />Send Love...Send Flowers. Call 563.690.1500 to order your bouquet today!</td></tr>
</table></div>
		</li></ul>    
</div><!-- #sidebar-primary -->


<div id="sidebar-secondary">

        
</div><!-- #sidebar-secondary -->        
                
    </div><!-- #main -->
    
    
    <div id="footer-widgets" class="clearfix">
                <div class="footer-widget-box">
                    </div>
        
        <div class="footer-widget-box">
                    </div>
        
        <div class="footer-widget-box footer-widget-box-last">
                    </div>
        
    </div>

    <div id="footer">
    
        <div id="copyrights">
            <p>
               
              &copy; 2017  <a href="http://kdth.radiodubuque.com/">
              AM 1370 KDTH              </a>
                        </p>
          <p><a href="http://radiodubuque.com/fcc_eeo/Radio-Dubuque-EEO-8-1-15-Thru-7-31-16.pdf" target="_blank">Radio Dubuque EEO Public File</a></p>
        </div>
        
</div><!-- #footer -->
    
</div><!-- #container -->

	<div style="display:none">
	</div>
      <script type="text/javascript">

          var pfHeaderImgUrl = '';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '1';
          var pfImagesSize = 'full-size';
          var pfImageDisplayStyle = 'right';
          var pfDisableEmail = '1';
          var pfDisablePDF = '1';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
      (function() {
            var e = document.createElement('script'); e.type="text/javascript";
            e.src = 'https://cdn.printfriendly.com/printfriendly.js';
            document.getElementsByTagName('head')[0].appendChild(e);
        })();
      </script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/comment-reply.min.js?ver=4.8'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201725'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/kdth.radiodubuque.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Junaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.8'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=2.9.8'></script>
<script type='text/javascript' src='http://kdth.radiodubuque.com/wp-includes/js/wp-embed.min.js?ver=4.8'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201725.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.0',blog:'105342466',post:'20096',tz:'-5',srv:'kdth.radiodubuque.com'} ]);
	_stq.push([ 'clickTrackerInit', '105342466', '20096' ]);
</script>

<script type='text/javascript'>
/* <![CDATA[ */
jQuery.noConflict();
jQuery(function(){ 
	jQuery('ul.menu-secondary').superfish({ 
	animation: {opacity:'show'},
autoArrows:  true,
                dropShadows: false, 
                speed: 200,
                delay: 800
                });
            });
jQuery('.menu-secondary-container').mobileMenu({
                defaultText: 'Navigation',
                className: 'menu-secondary-responsive',
                containerClass: 'menu-secondary-responsive-container',
                subMenuDash: '&ndash;'
            });

/* ]]> */
</script>
</body>
</html>